Email messages interruptions
Incident Report for Dashly
Resolved
This incident has been resolved
Posted Jun 09, 2022 - 17:02 UTC
Investigating
Email campaigns are not available at the moment, we are investigating this issue
Posted Jun 09, 2022 - 13:33 UTC
This incident affected: Management Portal (example).